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1 Getting Start

After successfully installed the system , first of all is to login to the web management
interface. You can either using IPv4 or IPv6 address to access GUI management
interface by using popular browser such as  Firefox or Internet Explorer. The
following is the step by step to tell how to create your unique IVR service.

1.1 Logon the system

After connect the Ethernet cable into the server machine, administrator need to use
a computer which had Firefox or IE installed and network connected in order to
connect to system GUI. For convenience, configuration computer is recommended
to have same subnet as the server. 

Start the browse, and type http://xxx.xxx.xxx.xxx:7000  or https://xxx.xxx.xxx.xxx:7001
to login the web manage where xxx.xxx.xxx.xxx is the IP address. 

After connected, you should able to see the following login page. Input the default
user ID "admin" and password "admin" and the validation  code (CAPTCHA) to
logon the system.

1.2 Change Default Password

The default password of "admin" is madden for easy to remember. To secure the
system access, it is recommended to change the default password as the follows.

Click ADMINISTRATION -> Account -> admin and the following screen will
appear. Input the new password at the Password and Confirm Password fields and
click the Apply button to take effective. Click logout to quit the system UI and relogin
by new password for confirmation.

http://xxx.xxx.xxx.xxx:7000
https://xxx.xxx.xxx.xxx:7001
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1.3 Setup IVR Server ID

The first step is to setup an unique IVR server ID. If each IVR server are independent
and not sharing same database or call flow,you can always set the Server ID to ivr1
as default. Otherwise, each server need have different server ID to identify each
server. First to add an IVR server by clicking SYSTEM  -> IVR Server List and
following will appear:

Click New and add the following information:

Parameter Name Value

Server ID ivr1 

Server Name IVR Server1
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Click Apply and you should see this Server ID was inserted.

Click SYSTEM -> Service Parameter and the following will appear:

Select ivr1 in the Server ID field and click apply.

1.4 Create IVR Account in Proxy/IPPBX

Before you can connect SIP IVR into your SIP Proxy or IPPBX, you need create a
SIP account to register or a predefine account. 

For UniSIP-6000 or UniPBX-2000 user, click Extension -> Extension -> New to
create an account for IVR.  The following screen will appear: 
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The following parameters are recommended:

Parameter
Name

Value

Extension Number **9 (you might change as your numbering plan)

SIP User ID **9 (you might change as your numbering plan)

SIP Password a secure password was required

Extension Type FXO/Trunk/Proxy

Contact Policy Register (You can choose to use Permanent contact as well)

Default Register
TTL

60 seconds
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Parameter
Name

Value

Max Contact
Supprot

1

Max Concurrent
Call

0 (it means no limitation)

Permanent
Contact 1

If you are using Permanent contact, the following is the
example to be set.
sip:**9@xxx.xxx.xxx.xxx:5063 where xxx.xxx.xxx.xxx is the IP
address of UniIVR

Click Apply to save it.

The next is to create a routing plan in order to route the call to UniIVR-7000 as
follows:

Click Feature -> Routing Plan -> New to create routing plan for IVR as follows (You
can create many routing plan based on your numbering plan to UniIVR).

Please input the following parameters:

mailto:sip:**9@xxx.xxx.xxx.xxx:5063
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Parameter
Name

Value

Pilot Number **9

Length ignore

Extension Group All

Route Period All the Time

Match Calling
Prefix

Ignore calling number

Hunt Type Round Robin

Remote Pilot
Number

Yes

Click Apply to save it.

Click Route List to add your UniIVR server as follows:

Parameter
Name

Value

Extension Number **09

Perference 0

Apply the above settings to system by click COMMIT.
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1.5 Connect to SIP Proxy

After create an IVR account in your SIP proxy or IP-PBX, the next is to setup the IVR
to connect to it. Click SYSTEM -> SIP Service as follows:

Parameter
Name

Value

Proxy Server IPV4 The SIP proxy IP address

Proxy Server IPV4
UDP Port

The UDP service port of SIP proxy

SIP TEL **9 (or the number you created in SIP proxy)

SIP User Name **9 (or the number you created in SIP proxy)

SIP User
Password

a secure password was required

Register Type Register

Register Expires
Time

60 seconds

Click Apply to save the settings.
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1.6 Commit the Changes

Because of the SIP Proxy server setting in IVR need restart to take effective, click
Administration -> Restart and the following will appear:

Click Restart to restart the service and take the setting effective.

1.7 Upload Required Prompts

Before you start to deploy your own call flow, you need prepare the required prompt
files. Click CALL FLOW -> Prompt Manager and the following will appear:

Click the  to create a directory and the following will appear:

Input your folder name (e.g. prompt) and click Apply. You should see the directory
was created.

Click the   to upload your prompt file. Please note that your prompt file must
comply the following rule in order to make it work.



Getting Start

 
15

File Extension:  wav
Encode           :  Linear PCM 16 bits, Mono
Sample Rate  : 8000 

Please upload all of your required prompt into the system under the created
directory.

1.8 Design Call Flow

Now you can start to design your first call flow. Click CALL FLOW -> Call Flow
Designer and the following will appear:

Click New and the following will appear:
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The first is to decide this call flow is for incoming call or outgoing call. Right click the

Start component  and you will see the following:
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For incoming call, set the call type to Incoming. For outgoing call, set the call type to
Outgoing. Click Apply to save it.

And now you can start to add component into your call flow. Click  and following
will appear:
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You can select different category of component and click the one you need and drop

it into your call flow. And use line  or  to connect  2 component together. 

For an incoming call flow, you must have at least the following:
   - Start: Call Type must set to Incoming

- Wait Call
- Answer Call

For an outgoing call flow, you must have at least the following:
- Start: Call Type must set to Outgoing
- Call Make

After you did the modification of call flow. click File -> Save to save it. 

1.9 Load and Run the Call Flow

After you complete the call flow design, you can run it on the selected channels by
clicking CALL FLOW -> Channel Manager and the following will appear:
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Select the channels you would like to run by using SHIFT + Channels for a range of
channels or Control + Channels to select the specified channels, and click Load
button. The following will appear:

 

Click the call flow you would like to run and Apply it. 

Then you can select these channels again and click Run button to start run the call
low.
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1.10 Make Testing Call

Using an IP phone or softphone, registered in your SIP Proxy or IPPBX,  dials to
routing prefix **9 (or your defined number) to test your call flow for incoming call. You
should hear your call flow prompt.
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2 Using the System

The administrator can logon the web GUI interface to manage the system service. It
provides the system setting, call flow editor, real time system status monitor etc.  The
default login URL for administrator login is http://xxx.xxx.xxx.xxx:7000 or https://
xxx.xxx.xxx.xxx:7001 and default login id is "admin" and password is "admin".

 

2.1 Home

The home page of the system, provides the system summary information. The
administrator can have a quick way to view the major system settings.

The detail of each parameter are described as below:

Parameter Name Description

Product Name The product name 

System Version The current running system release

Web Release The current running web release

http://xxx.xxx.xxx.xxx:7000
https://xxx.xxx.xxx.xxx:7001
https://xxx.xxx.xxx.xxx:7001
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2.2 System

The system parameters including the SIP, service, IVR and license settings. Click
the SYSTEM and will see the setting in the left panel as follows.

2.2.1 IVR Server List

IVR Server List is useful when you have more than 1 IVR server and would like to
have central management. In this case, each IVR server must have an unique IVR
Server ID in order to identify it. For most of application, each IVR server have their
own call flow and management, therefore there is not matter which ID is used. To
add an IVR server into the server list, click SYSTEM -> IVR Server List and the
following will appear:

Click New to add a new IVR server into the list as follows:
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The detail of each parameter is described as below:

Parameter Name Description

Server ID The unique server ID for each IVR server

Server Name The name of IVR server

After you create the IVR server list, you must assign it in the SYSTEM -> Service
Parameter for each IVR server. 

2.2.2 SIP Service

This is the setting for connected SIP proxy. Click SYSTEM -> Proxy Setting and
following will appear. 

The detail of each parameter is described as below:
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Parameter Name Description

Attached IPV4 Interface The network interface to be attached for SIP IVR
service.

Proxy Server IPV4 The IPV4 address of SIP proxy server

Proxy Server IPV4 UDP
Port

The UDP port used to connected to IPV4 SIP Proxy
Server

Local SIP IPV4 UDP Port This is local IPV4 SIP UDP port will be used for SIP
IVR service.

Attached IPV6 Interface
Name

The network interface will be used or IPV6 service

Proxy Server IPV6 The IPV6 address of SIP proxy server

Proxy Server IPV6 UDP
port

The UDP port used to connected to IPV6 SIP Proxy
Server

Local SIP V6 UDP Port This is local IPV6 SIP UDP port will be used for SIP
IVR service.

SIP Domain The SIP domain will be used for calling to SIP proxy
server.

SIP TEL The SIP account on the SIP proxy server to be used
for this IVR server. Administrator need create an SIP
account in for this IVR server order to connect
together.

SIP User Name SIP user name for authentication

SIP User Password SIP user password is used when calling to SIP proxy
server.

Register Type The connection type to SIP proxy server. It could be
dynamic register or predefine. Normally, it could be
predefine.

Register Expires Time
(sec)

The register TTL if SIP proxy server requires to
register.



Using the System

 
25

2.2.3 Service Parameter

This is the setting related to SIP IVR service. Click SYSTEM -> Service Parameter
to view the settings as below.

The detail of each parameter is described as below:

Parameter
Name

Description

Local Media UDP
Start Port

The is the media UDP starting port will be used for IVR
server service. The default is 40000. It means the UDP
ports will be used will be 40000 to 40000+ (Max service
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Parameter
Name

Description

channel * 10).

Enabled Codec 1-
5

The codec will be used for IVR service.

System Internal
User

The system GUI used internal users for system control and
management.

System Internal
Password

The system GUI used internal users for system control and
management.

Server ID Unique IVR server ID to identify this server within a central
management architecture.

Websocket port The websocket port used for channel debug

Fax Server ID Fax Server station ID (only available when you have fax
license)

System Internal
Hook Timer(sec)

System internal http hook time out for those ACD
integration. The default is 10 seconds.

IVR Recording
Streaming Server 

This could be the ASR server which receive the real time
Linear PCM voice data and initiate the ASR for voice
recognition.

Stream Receiving
Starting Port 

The ASR server receiving port. Each channel use 1 UDP
port. For example, you have 10 channels ASR service and
starting port is 30000. Thus server need listen on 30000 to
30009, in total 10 ports.

Silence Detection
Mode

For voice recording, this is the silence detection method
could be used. It is recommend to use adaptive silence
detection.

Silence Detect
Threshold

The signal level to be detected as a silence. Below this
value, SDT will think it is a silence. The default is 1200.
Higher threshold indicates more sensitive on silence and
lower threshold indicates less sensitive to detect the
silence.

Min Duration of
Silence (ms)

Minimum duration of silence (in msec) before silence is
reported. The default is 400 ms.
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Parameter
Name

Description

Non-Silence
Recalculate Time
(ms)

The interval (in msec) to recalculate threshold in non-silence
condition when adaptive silence detection is set. The
default is 400 ms.

Silence
Recalculate Time
(ms)

The interval (in msec) to recalculate threshold in silence
condition when adaptive silence detection is set. The
default is 2000 ms.

No Response Time
Out (sec) 

The SIP sending no response timeout.

Report Keeping
Days

The max days to keep reporting data.

2.2.4 SIP Timer

There are some SIP related timer in this page for system tuning purpose. Click 
SYSTEM->SIP Timer to view and modify the settings.

The detail of each parameter is described as below:

Parameter
Name

Description

SIP T1 The T1 timer, which is defined in milliseconds, specifies the
amount of round trip time (RTT), that the client will attempt to
send a SIP Request and expect a response. By default, the
T1 timer is set to 500ms. 

SIP T2 Maximum retransmission interval for non-INVITE requests
and INVITE responses. The default value is 4000 ms.
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Parameter
Name

Description

SIP T4  Maximum duration that a message can remain in the
network. The default value is 5000 ms.

Session Expires Session expires timer for calling checking (session timer
RFC 4028)

2.2.5 Web Service

This page come with web GUI service settings. Click SYSTEM -> WEB Service to
view and change the settings.

The detail of each parameter is described as below:

Parameter Name Description

HTTP Service Port The TCP service port for web GUI management. The
default value for administrator and supervisor login is
7000. The default value for extension login is 81.

HTTPS Service Port The TCP service port for HTTPS (SSL) web GUI
management. The default value  for administrator and
supervisor login is 7001. The default value for extension
SSL login is 82.



Using the System

 
29

Parameter Name Description

Display Data Rows
per Page 

Number of data rows will be displayed per page. The
default is 15.

SOAP Provisioning
Service

The HTTP or HTTPS  interface for SOAP provisioning for
extension and call features. It is recommended to use
HTTPS for security reason. The default service port is
TCP 7080. 

Use Validation Code
on Login

Use CAPTCHA to against the response is not generated
by a computer or not for logon. It is recommended to
enable it for security reason.

Write Access Log
Count

Number of authenticate failure access will write a log into
Web provisioning report.

Block Access IP Count Number of authenticate failure access will block this IP
address.

Block Access IP Time
(minutes)

How long the IP will be blocked

Click SSL Certificate Upload to upload you own certificate.

Click Customize Web Logo to upload you own logo for web management interface.

Click Web login Blocked IP to check whether an IP is blocked or not and unblock it
when necessary.

2.2.6 Database

This is for system database settings. Click SYSTEM -> Database to view and
change the settings.
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The detail of each parameter is described as below:

Parameter Name Description

MYSQL DB Server MYSQL database server IP address. The default value is
127.0.0.1

MYSQL Port MYSQL database connection port.   The default port is
3306.

MYSQL User ID MYSQL access user ID

MYSQL Password MYSQL access password

MYSQL Database
Name

MYSQL Database Name

2.2.7 License

This the license granted for the system. It can only be used on this dedicate machine.
There is no any responsibilities for error, omissions or any damages resulting from
the wrong use of the license. Click SYSTEM -> License to view or import/export the
license.

The detail of each parameter is described as below:

Parameter Name Description

Product Name The licensed product name

Serial ID The serial ID generated for each license

Machine ID The machine ID used for the license
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Parameter Name Description

Feature The feature list of this license

License Key The license key generated

Expired Date The expired date for the license

2.2.8 Debug

The Debug Configuration page is used to manage the debug level and modules.
Please only turn on the debug level under the recommendation from supporting FAE.
Or the system performance might be greatly affected. In order to receive the system
debug log, the administrator need prepare a  PC which installed a SYSLOGD
server. It is recommended that both server and syslogd PC stay at same network
because of the large packet might be send over the network. Click SYSTEM ->
Debug to view and change the debug settings.

The detail of each parameter is described as below:  
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Parameter Name Description

Write to Log File Whether to write the call flow debug log to file for
tracing?

Syslog Debug Enable syslog debug or not

Syslog Debug Server IP The syslogd server to receive the debug information.
The port to receive the syslog is 514.

Debug Channel The channels to be debug

Debug Level This parameter is the detail level of generating debug
information. The default level is "Warning". When you
change it to  debug, the system will generate hug log
and might greatly affect the system performance.
Please only change it under the supervision of FAE.

Module List The target module to be debug. Please only change it
under the supervision of FAE.

2.2.9 System Alert

The system can be set to  automatically send the system event notice to
administrator through syslog or email. Click SYSTEM -> System Alert to view and
change the settings.

The detail of each parameter is described as below:
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Parameter
Name

Description

System Alert
Threshold

The filter level to send the alert out. The default is  level of
"Notice".

Alert to Syslog Whether to send the system alert to syslogd server or not.

Syslog Receiver IP The syslogd server to receive the system alert.

Alert to Email Whether to send the system alert to the listed email account
or not.

SMTP Server The SMTP server for sending the system alert mail notice.

SMTP Port The SMTP server port. For SSL the default is 465 and for
StartSSL or none, the default is 25.

SSL Type The SMTP server supported SSL Type, it can be none,
STARTTLS or SSL.

Email From The email sending account (FROM)

Email To List The email addresses to receive the system alert email. 

Email Subject The email subject for the system alert notice. The variable 
"$HOSTIP$", Host IP address, could be used in the subject
to make the subject easy to be read (e.g. System Alert
Notice from $HOSTIP$).

Email User ID The email sending account ID

Email User
Password

The email sending account password

2.3 Call Flow

Call Flow contains the call flow designer, channel, information and prompt
management. 
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2.3.1 Call Flow Designer

Call Flow Designer is use to create your unique IVR flow. It provides easy designing
interface and flexible logic flow design to build a customized flow based on your
requirement. System will keep up-to 10 saving historical call flow for safety purpose.
Click CALL FLOW-> Call Flow Designer to manage your call flow and the following
will appear:

Click Modify the call flow and the following will appear:

The detail of each parameter is described as below:
  

Parameter Name Description

Call Flow Name The name of call flow
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Parameter Name Description

Update Sequence ID The automatically sequence update for each saving

Release Version The call flow version/release for reference

Information Group ID The call flow used Information group which contains
working hour, holiday and digit manipulation.

Component Count Current component count

Update Time Last update time

Update User Last update user

Description The description of this call flow

Click Update History and the history will be showed as follows:

You can select an historical call flow and click restore to make it become newest.

Click New to add a new call flow as follows:
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After you finish the editing, click  save and the following will appear:
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The detail of each parameter is described as below:
  

Parameter Name Description

Call Flow Name The name of call flow

Release Version The call flow version/release for reference

Information Group ID The call flow used Information group which contains
working hour, holiday and digit manipulation.

Description The description of this call flow

2.3.1.1 Menu

The top of call flow designer contains a mean and operation bar as follows:

The File menu can be use to create, open, close, save or import/export call flows as
follows:

The Edit  menu can be use to copy, paste, cut or delete components as follows:
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The Search menu can be used to  search a specified component based on different
criteria as follows: 

The View menu can be used to change the grid size or related settings as follows:
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The Windows menu can be used to select different call flow when you have multiple
call flow opened at same time as follows:

2.3.1.2 Operation Bar

The operation bar contains the following:

 : New a call flow

: Open a call flow

: Save the current call flow

: Cut the selected components
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: Copy the selected components

: Paste the selected components to call flow

: Selecting components

 : Connect 2 components using a direct line

: Connect 2 components using a curve line

: Moving components

: Show or hide grid

: Fit into grid line or not

: Search a components

: General component

: Call flow related components

: Call related components

: IVR related components

: Database related components

: ACD related components

2.3.1.3 General Component

The General component contains the general purpose components. Click  as the
following components will be display for your selection:
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2.3.1.3.1  Variable Define

This component is used to define used variable. The system provides 3 types of
variable: Number, String and Time variable. 

The following is the rule for using a variable:
1. Each variable must define it in "Variable  Define" component  before it can be
used. 
2. Each variable is channel and call flow wide visible.  Each channel's variable
cannot be shared.
3. If a sub flow need refer to a variable in the main flow,  you must define it and check
"No Initial Value" in order to keep the original value from main flow.
4. If a variable is defined more than once, new define will overwrite the existed one.
5. Each variable will be cleaned once the call is completed.   

Click   and drop it into your call flow.  Right click the component and the
properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Variable Name The variable name will be used. Each variable need
to be unique. And it is recommended to use v or _v
as a prefix to make it easy to identity. 

Variable Type The system support 3 types of variable: String
variable, Number variable and Time variable. Only
Number variable can be used in the math expression
and time variable should be used for time operations.

Default Value The default value will be assigned to this variable.  If
keep it blank, the system will set 0 for number
variable, empty for string variable, 0 for time variable.

No Initial Value This is used when a sub flow is using a variable from
main flow. Check it when the sub flow need able to
use the value from main flow.

Next Goto Next component to be followed
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2.3.1.3.2  Math Expression

The Math Expression component is used do the math calculation. The variable can
be used only is number variable in this match expression. 

Click  and drop it into your call flow. Right click the component and the
properties will be display as follows:

The detail of each parameter is described as below:
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Parameter Name Description

Expression The match expression will be execute. It can contain
variables in the expression. And it must contains a
assignment operator in order to return the result into
call flow.

Error Goto In case there is an error occurred, this component will
be followed

Next Goto Next component to be followed

For math expression, the following is the built-in functions supported:

Function
Name

Argument
Count

Explanation Example

sin 1 sine function y=sin(x)

cos 1 cosine function y=cos(x)

tan 1 tangens function y=tan(x)

asin 1 arcus sine function y=asin(x)

acos 1 arcus cosine function y=acos(x)

atan 1 arcus tangens function y=atan(x)

sinh 1 hyperbolic sine function y=sinh(x)

cosh 1 hyperbolic cosine y=cosh(x)

tanh 1 hyperbolic tangens function y=tanh(x)

asinh 1 hyperbolic arcus sine
function

y=asinh(x)

acosh 1 hyperbolic arcus tangens
function

y=acosh(x)

atanh 1 hyperbolic arcur tangens
function

y=atanh(x)

log2 1 logarithm to the base 2 y=log2(x)

log10 1 logarithm to the base 10 y=log10(x)

log 1 logarithm to the base 10 y=log(x)

ln 1 logarithm to base e
(2.71828...)

y=ln(x)

exp 1 e raised to the power of x y=exp(x)

sqrt 1 square root of a value y=sqrt(x)

sign 1 sign function -1 if x<0; 1 if
x>0

y=sign(x)
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Function
Name

Argument
Count

Explanation Example

rint 1 round to nearest integer  y=rint(x)

abs 1 absolute value  y=abs(x)

min var. min of all arguments  y=min(x,2,5)

max var. max of all arguments  y=max(x,z)

sum var. sum of all arguments  y=sum(x,5,z)

avg var. mean value of all arguments  y=avg(x,z)

The following is the built-in binary operator:

Operator Meaning

= assignment

&& logical and

|| logical or

<= less or equal

>= greater or equal

!= not equal

== equal

> greater than

< less than

+ addition

- subtraction

* multiplication

/ division

^ raise x to the power of y

*The assignment operator is special since it changes one of its arguments and can
only by applied to variables.

The following is the example for the math expression:

vCnt=vCnt+1

vTotal=vCntA+vCntB+2000
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2.3.1.3.3  IF

If component is used to do the logical operation. Click  and drag it into your call
flow. Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Operand 1 The operand which can be value or a variable. For
variable, check the Var tag and select the variable
you would like to use.

Operator The logical operation which can be >, <, = etc.

Operand 2 The operand which can be value or a variable. For
variable, check the Var tag and select the variable
you would like to use.

Logical Operator and or or operator 

True Goto Next component to be followed if the result is true.

False Goto Next component to be followed if the result is false.
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2.3.1.3.4  Case

The Case component is used to switch based on different value. It is useful
especially when you receive DTMF digits from caller and would like to switch to
different announcement. 

Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:

The detail of each parameter is described as below:
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Parameter Name Description

Matched Variable variable to be used for matching the following case
value

Index Up-to 10 value can be matched. If you need more
than 10 value for matching, default goto can be used
to cascade together.

Case Value The value to be matched.

Goto If the variable's value matched the Case Value, this is
the component will be followed.

Default Goto If not mach any above value, this is the component will
be followed.

2.3.1.3.5  Generate Random Number

This component is used to generate a random number. Click  and drag it into
your call flow. Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
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Parameter Name Description

Range The generated number should be within this range
(maximum and maximum)

Stored Variable The variable to be used for storing the generated
random number.

Success Goto Next component to be followed

2.3.1.3.6  Sleep

This component is used to sleep for a certain period. Click  and drag it into
your call flow. Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Sleep Time (msec) The time to be sleep (wait) in mini second

Next Goto Next component to be followed
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2.3.1.3.7  Working Hour/Holiday Checking

This component is used to check whether now is working hour, off hour or holiday.
Those definition was on Information Group. To associate an information group into a
call flow, you can modify the call flow or select the information group when you save
it.

Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Information Group If it is set to Default, the system will use the call flow
based Information group. Other, select the used
information group here.

Holiday Prompt File If you have setup a holiday prompt, this is the variable
that you can used for store the holiday prompt in
order to play back.

Working Type The variable to be used for storing the working hour
type in order to have different call flow.
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Parameter Name Description

Holiday  Goto Next component to be followed when the checking
result is holiday

Working Hour Goto Next component to be followed when the checking
result is working hour. The next component can check
working hour type in order to have different call flow.

Off Hour goto Next component to be followed when the checking
result is off hour. If there is not any matched time
segment, holiday or special day. This off hour will be
handled as default.

Special Day Working
Hour Goto

Next component to be followed when the checking
result is a special working day and now is working
hour.

Special Day Off Hour
Goto

Next component to be followed when the checking
result is a special working day and now is off hour.

2.3.1.3.8  Digit Manipulation

This component is used to do the digit manipulation based on Information Group. To
associate an information group into a call flow, you can modify the call flow or select
the information group when you save it.

Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Information Group If it is set to Default, the system will use the call flow
based Information group. Other, select the used
information group here.

Input Variable The variable to be used as an input for the DM rule

Output Variable The variable to be used for storing the DM result

Next Goto Next component to be followed
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2.3.1.3.9  String Operation

This component is used to do the manipulation of string variable. It can be used to
do the copy, get string length, compare etc. operations.

Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Function The applied string function

Operation The detail parameter for each functions

Next Goto Next component to be followed

The detail of each function is described as below:
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Function Name Description

Append Append source variable or value into destination variable.
You can only append first x characters into destination
variable by input the length.

Copy Copy source variable or value into destination variable.
You can select copy only first x characters or whole string
into destination variable.

Find Find specified variable or pattern from the source and put
the found position into result variable. If it is not found, the
result will be -1. Greater than -1 indicates the pattern was
found and the position will be reported.

Compare Compare source 1 and source 2's string value and put the
result into result variable. You can optional to only compare
first x character by assign a length.  If result > 0 means
source 1 is greater than source 2. If result < 0 means
source 1 is less than source 2. If result is equal to 0, it
mean source 1 is equal to source 2.

Length Calculate source's string length and put the string length
into the result variable.

Left String Get first (left) x (by assigned length) characters from the
source variable and assigned to destination variable. 

Right String Get last (left) x (by assigned length) characters from the
source variable and assigned to destination variable. 

Sub String Retrieve sub-string from the source by assigning starting
position and the retrieve length and assign to the
destination variable. The position started from 0 to indicate
first character.

Delete Delete sub-string from the source by assigning starting
position and the retrieve length and assign to the
destination variable. The position started from 0 to indicate
first character.

Upper Upper all characters in source and assign to destination
variable.

Lower Lower all characters in source and assign to destination
variable.
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Function Name Description

Insert Insert source into destination by assigning start position
(starting from 0)

Trim to Digit Trim the source variable to only have telephone digits (0-9,
*, #) and stored the result into destination variable.

String to Number Convert a String variable into a Number variable

Number to String Convert a Time variable into a String variable

String to Time Convert a String Variable into a Time variable. The input
string format has to be" yyyy/mm/dd hh:nn:ss" or "yyy-mm-
dd hh:nn:ss".

2.3.1.3.10  Get System Time

This component is used to get local system time. Click  and drag it into your
call flow. Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
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Parameter Name Description

Stored Time Variable The time variable to store the current local system
time.

Next Goto Next component to be followed

2.3.1.3.11  Calculate Time

This component is used to do the calculate of time duration or get new time. Click 

 and drag it into your call flow. Right click the component and the properties will
be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Calculate Mode How to calculate the time. 
Get Time Duration:  Stop Time - Start Time. If stop
time is less then start time, the result will be 0. The
result is a number variable.
Get Past Time: Stop Time - Start Time. The result is
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Parameter Name Description

a time variable.
Get Future Time: Stop Time + Start Time. The result
is a time variable.

Start Time The Starting Time

Stop Time The Stop Time

Calculate Variable The variable to store the calculated result.

Next Goto Next component to be followed

2.3.1.3.12  Get String Time

This component is used to convert a time variable into a string variable based on

selected format. Click  and drag it into your call flow. Right click the component
and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Get Time Format The converted time format:
 Date & Time: The output string will have date and
time
 Date Only: The output string will have date only
 Time Only: The output string will have time only
  Weekday: The output string is 1: Monday, 2:
Tuesday... 7:Sunday

Year Format The system support 4 digits  year  (YYYY), 2 digits
year (YY) or Taiwan Year (YYY)

Date Format The date format supported

Delimiter The date or time delimiter

Input Variable The time variable to be converted

Output Variable The variable to store the output string

Next Goto Next component to be followed

2.3.1.3.13  Remark

This component is used to put a remark on your call flow. Click  and drag it into
your call flow. Right click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Font Color The color to display the remark text

Font Size The display text size 

Font Style The display text style

Remark The contents of this remark which will be display in
call flow

2.3.1.3.14  Send Email

This component is used to send a email out with an attachment. Click  and
drag it into your call flow. Right click the component and the properties will be display
as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

SMTP Server The SMTP server which can be an domain name or
IP address 

SMTP Server Port The STMP Server port.  Normally, this port is set to
25 but for SSL it could be others such as 465.

SMTP Mode The SMTP server supported security options which
could be  non-SSL, STARTTLS or SSL.

Email From The email sending email address for SMTP server.

Email To The email receiver email address

Email Subject The subject of this mail

Attached File Dir If you have attached file, this is the directory contains
the attached file. 
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Parameter Name Description

Attached File The file to be attached

Email User ID The email sending account ID

Email User Password The email sending account password

Email Body The body of this mail

Email Input Variable This is the keyword to be replaced in the subject and
body. The system will look at the email subject and
body and find those keywords (Email Input Variable) 
and replace it by using the value of "Replaced
Variable". This is useful to make the subject or body
more readable and dynamic.

Replaced Variable This is the mapped variable which value will replace
the corresponding keyword in Email Input Variable.

Next Goto Next component to be followed

2.3.1.3.15  System Calling

This component is used to calling a system script to run a specified task such as
move a recorded file, delete a file etc.  Those script file need to be installed on the

system running patch such as /usr/local/sbin.  Click  and drag it into your call
flow. Right click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Command String The shell script or command line to be executed. The
system will call system to run this script or command.
The command is able to carry the system variable by
using the Command Input Variable and Mapped
Variable. In order to make the command to be ran
successfully, the script need to be located in system
running patch such as /usr/local/sbin, /usr/local/bin. 
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Parameter Name Description

Max Execution Time Max running time to execute this system script.

Command Input Variable This is the keyword to be replaced in the Command
String. The system will look at the Command String
and find those keywords (Command Input Variable) 
and replace it by using the value of "Mapped
Variable". This is useful to make the Command
String parameters based on your collected data.

Mapped Variable This is the mapped variable which value will replace
the corresponding keyword in Command Input
Variable.

Next Goto Next component to be followed if the script returning a
success code (exit 0)

Error Goto Next component to be followed if the script returning a
failed code.

Examples of local rename script contents:

#!/bin/bash
#
cd /opt/ezvoicetek/ezivr7000/userdata/
mv -f $1 $2 > /dev/null 2>&1
exit $?

2.3.1.3.16  Key Path Trace

This component is used to insert a key path trace report into report database. It will
only be started when CDR is turned ON on Start component, otherwise, this

component will be ignored. Click  and drag it into your call flow. Right click the
component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Key Tag The Tag will be recorded for reporting. This tag will
be the target for reporting.

Key Value The value will be displayed on Call History Report
Detail for tracking purpose.

Next Goto Next component to be followed.

Remark The contents of this remark which will be display in
call flow

2.3.1.4 Flow Component

The General component contains the call flow related components. Click  as the
following components will be display for your selection:
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2.3.1.4.1  Start

Start component is the beginning of call flow. The call flow will run from here for each

call. After you create a call flow, the Start component   is created automatically
for you. 
Right click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

First Digit Time Out After complete the playing of announcement, this is
the time to wait the first digit. The recommended
value is 6-10 seconds.

Inter Digit Time Out After first digit was received, this the  time to wait the
incoming digit. The default is 3 seconds.

Call Type The call type of this call flow. If this call flow is used to
dial out, set it to Outgoing. Otherwise, make it to
Incoming.

Incoming Call Prefix For incoming call, you can optionally specify call flow
to only accept those calls' called number is matching
the Incoming Call Prefix. This is useful to define which
channels to  If it is empty, the call flow will accept any
calls. 

CTI Server Type What kind of CTI server will be supported:
Default: Using default CTI server type which is fully
integrated with ACD.
UUI (hex), using UUI hex mode to carry CTI data. 
UUI (string), using UUI string to carry CTI data.

CDR Turned on CDR for this call flow or not. Please turned
on CDR if you would like to use Key Path Trace
feature.

Next Goto Next component to be followed

2.3.1.4.2  Execute Sub Flow

This component is used to execute a sub call flow. Once the sub call flow is finished,

it will return to it and execute the next goto component. Click  and drag it into
your call flow. Right click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Sub Flow ID The call flow will be executed as a sub flow

Next Goto Next component to be followed after retuning form the
sub call flow.

2.3.1.4.3  Legacy Hook

This component is used to execute a custom legacy hook.  This hook has to be
running on the same Linux server.  Please contact technical support for detail.  Click 

 and drag it into your call flow. Right click the component and the properties will
be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Hook ID The ID is used to identify the hook request. Thus the
custom hook AP will know which request is
processed.  

Max Time to Wait The max time to wait the hook to return. If over this
timeout, it will go to Timeout Goto component.

Result Code from Hook The variable to store the returning code from hook

Passed Variable The variable will be passed to hook AP

Error Goto If the hook is returning error (not success), this
component will be followed.
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Parameter Name Description

Timeout Goto If the hook doesn't return within max time to wait, this
component will be followed.

Next Goto If the hook is returning success (OK), this component
will be followed.

2.3.1.4.4  Http Hook

This component is used to execute a custom http or https hook. This hook is calling a
http URL and carry the parameter into the URL by using GET or POST method. Thus
the hook can be written on any web technologies and remotely. 

For GET method, the http URL can be http://192.168.0.1/hook ? var1=sys_var 
(sys_var is the internal string variable and its value will be replaced to it)
For POST method, the http URL can be https://192.168.0.1/hook and post field will
be var1=sys_var 

The http hook has to return the following format:
ret=x                                      (0: success, <0: failure or error)
var=variable_name,value   (optional, variable_name has to be a string variable and
defined in the calling call flow. You can have multiple var= to returning multiple
variable)

An example of http output is:
ret=0
var=ret_var1,123
var=ret_var2,abc

In this case, the system will update ret_var1 to "123" and ret_var2 to "abc" in the call
flow. Thus you can process these 2 return value to meet your requirements.

This is the recommended method to link to your legacy system or external database
connection.

Please contact technical support for detail.  Click  and drag it into your call
flow. Right click the component and the properties will be display as follows:

http://192.168.0.1/hook
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The detail of each parameter is described as below:
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Parameter Name Description

HTTP URL The http or https URL will be called. It can support get
and post for the parameters.   
For GET method, the http URL can be 
http://192.168.0.1/hook ?var1=sys_var. 
For POST method, the http URL can be
https://192.168.0.1/hook and post field will be
var1=sys_var.

Post Field The POST parameter will be send to web server.

Max Time to Wait The max time in seconds to wait the hook to return. If
over this timeout, it will go to Timeout Goto
component.

Result Code from Hook The variable to store the returning code from hook

URL Input Variable This is the keyword to be replaced in the HTTP URL.
The system will look at the HTTP URL and find those
keywords (URL Input Variable)  and replace it by
using the value of "Replaced Variable". This is useful
to make the HTTP URL based on your collected data.

Replaced Variable This is the mapped variable which value will replace
the corresponding keyword in URL Input Variable.

Error Goto If the hook is returning error (ret<0), this component
will be followed.

Timeout Goto If the hook doesn't return within max time to wait, this
component will be followed.

Next Goto If the hook is returning success (ret=0), this
component will be followed.

2.3.1.4.5  Debug Message

This component is used to send a call flow debug message into debug log or

debugger.  Click  and drag it into your call flow. Right click the component and
the properties will be display as follows:

http://192.168.0.1/hook
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The detail of each parameter is described as below:
  

Parameter Name Description

Debug Message The debug message will be recorded or send to
debugger.

Debug Input Variable This is the keyword to be replaced in the debug
message. The system will look at the debug
message  and find those keywords (Debug Input
Variable)  and replace it by using the value of
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Parameter Name Description

"Replaced Variable". This is useful to make the
Debug Message  together with your collected
information.

Replaced Variable This is the mapped variable which value will replace
the corresponding keyword in Debug  Input Variable.

Next Goto If the hook is returning success (ret=0), this
component will be followed.

2.3.1.4.6  System Event Message

This component is used to send a call flow system alerting message into call flow

alert or debugger.  Click  and drag it into your call flow. Right click the
component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Event Level The event message severity level.

Event Message The event message will be recorded or send to
debugger.
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Parameter Name Description

Event Input Variable This is the keyword to be replaced in the debug
message. The system will look at the event message
 and find those keywords (Event Input Variable)  and
replace it by using the value of "Replaced Variable".
This is useful to make the Event Message  together
with your collected information.

Replaced Variable This is the mapped variable which value will replace
the corresponding keyword in Event  Input Variable.

Next Goto If the hook is returning success (ret=0), this
component will be followed.

2.3.1.4.7  Critical Section Start

This component is used to ensure that all followed components within critical section
start and critical section stop will be executed event when call is disconnected.
Please make sure you don't have IVR related components or blocked components
within critical start and stop. And start/stop must be a pair.

 Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:

The detail of each parameter is described as below:
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Parameter Name Description

Next Goto Next component to be followed

2.3.1.4.8  Critical Section Stop

This component is used to ensure that all followed components within critical section
start and critical section stop will be executed event when call is disconnected.
Please make sure you don't have IVR related components or blocked components
within critical start and stop. And start/stop must be a pair.

 Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Next Goto Next component to be followed

2.3.1.4.9  Goto

This component is used to jump to another component directly.

 Click  and drag it into your call flow. Right click the component and the
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properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Goto Component ID The component ID will be jumped to.

2.3.1.4.10  Quit

This component is used to quit this call flow. The existing call will be disconnected. 

 Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:

There is no parameter is required except remark.
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2.3.1.5 Call Component

The General component contains the call related components. Click  as the
following components will be display for your selection:

 

2.3.1.5.1  Wait Incoming Call

This component is used to waiting for a incoming call. This component is necessary
for an incoming call flow. IVR will stop on this component until there is a incoming call

arrived. Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Send Ringing Whether to send 180 (ringing) or 183 (early media)?
After 183 was sent, early media will be started and
can start the play prompt without answer.

Called Number The called number for this call

Calling Number The calling number for this call

CTI Variable The incoming call carried CTI data 

Skill Variable The incoming call carried Skill Information

Diversion User The Diversion User part for this call
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Parameter Name Description

Diversion Reason The Diversion Reason for this call

Call ID SIP Call ID for this call

Prefix Removed Called
Number

The called number after remove the IVR incoming
prefix

Next Goto Next component to be followed after retuning form the
sub call flow.

2.3.1.5.2  Make Outgoing Call

This component is used to make a call out. This component is necessary for an

outgoing call flow. Click  and drag it into your call flow. Right click the
component and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Called Number The called number for this call
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Parameter Name Description

Calling Number The calling number for this call

Answer Time Out How long in second to wait the called party answer?

Send Notify to Answer Whether IVR will send NOTIFY to tell the called party
answer or not? It is useful when you need called party
answer automatically. However, please make sure
the called party can support this feature. Please
contact FAE for detail.

Wait Answer Detect
Result

Whether to wait the answering detection result or not?
It only support those gateway who can send SIP
message to tell the answering result. Please don't
enable it unless you have confirmed your SIP
gateway can support this feature.

Wait Answer Detect Time
Out

How long to wait the answering result event from SIP
gateway.

Billing User The Billing user carried for this call. It is only
supported when you are using UniSIP-6000 or
UniPBX-2000.

CTI Variable The carried CTI data for this call. The format is
ctidata1,ctidata2

Skill Variable The carried Skill Information for this call. The format is
skillid1,skillid2

Call ID SIP Call ID for this call

SIP Reason Code The SIP reason code for this call out result

Connected Goto The component will be followed if call is connected
(200 OK)

No Answer Goto The component will be followed if call is not answered
by called (487)

Busy Goto The component will be followed if called party is busy
(486)

Not Found Goto The component will be followed if called party is not
found (404)
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Parameter Name Description

Unavailable Goto The component will be followed if called party is not
able to take this call (480)

Forbidden Goto The component will be followed if called party is
forbidden this call (403)

Others Goto The component will be followed if called party reject
this call.

Voice Goto This only valid when answering detection was turned
one and the SIP gateway can support the answering
detection. When called party is a human answer, this
component will be followed.

Answering Machine Goto This only valid when answering detection was turned
one and the SIP gateway can support the answering
detection. When called party is a answering machine,
this component will be followed.

Silence Goto This only valid when answering detection was turned
one and the SIP gateway can support the answering
detection. When called party is silence, this
component will be followed.

2.3.1.5.3  Answer Incoming Call

This component is used to answer an incoming call . Click  and drag it into
your call flow. Right click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Next Goto The component will be followed if call is answered
successfully.

Error Goto The component will be followed if call is not able to
answer it.

2.3.1.5.4  Transfer Call

This component is used to transfer an existing call. This call could an incoming call,

outgoing call or second call.  Click  and drag it into your call flow. Right click the
component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Transfer Mode The system support 2 types of transfer:
1. Blind Transfer: This mode will transfer the existing
call to transferred number without second call.
2. Consultant Transfer: This mode need IVR make
2nd call and transfer to it.

Transferred  Number It is only valid for blind transfer mode.  This is the
number to be transferred.

Transfer ANI It is only valid for blind transfer mode.  This is the
calling number (ANI) to be used (carried in Refer-By
header). In SIP proxy server or transferred party need
enabled the feature to "use Refer-By as ANI" to make
it working.

Billing User The Billing user carried for this transferred call. It is
only supported when you are using UniSIP-6000 or
UniPBX-2000.

CTI Data The carried CTI data for this transferred call. The
format is ctidata1,ctidata2

Skill The carried Skill Information for this transferred call.
The format is skillid1,skillid2

SIP Reason Code The SIP reason code for this transferred call result

Connected Goto The component will be followed if transferred call is
connected (200 OK)

No Answer Goto The component will be followed if transferred call is
not answered by called (487)

Busy Goto The component will be followed if transferred called
party is busy (486)

Not Found Goto The component will be followed if transferred called
party is not found (404)

Unavailable Goto The component will be followed if transferred called
party is not able to take this call (480)
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Parameter Name Description

Forbidden Goto The component will be followed if transferred called
party is forbidden this call (403)

Others Goto The component will be followed if transferred called
party reject this call.

2.3.1.5.5  Hold Call

This component is used to hold an existing call . Click  and drag it into your call
flow. Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Next Goto The component will be followed if call is hold
successfully.

Error Goto The component will be followed if call is not able to
hold it.
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2.3.1.5.6  Unhold Call

This component is used to hold an existing call . Click  and drag it into your call
flow. Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Next Goto The component will be followed if call is unhold
successfully.

Error Goto The component will be followed if call is not able to
unhold it.

2.3.1.5.7  Redirect Call

This component is used to redirect a incoming call before you answer it.  This

component can be used only before answer the incoming call. Click  and drag
it into your call flow. Right click the component and the properties will be display as
follows:



Using the System

 
87

The detail of each parameter is described as below:
  

Parameter Name Description

Redirect Number The number will be redirected (302 moved)

CTI Data The carried CTI data for this redirected call. The
format is ctidata1,ctidata2

Skill The carried Skill Information for this redirected call.
The format is skillid1,skillid2

Billing User The Billing user carried for this redirected call. It is
only supported when you are using UniSIP-6000 or
UniPBX-2000.

Next Goto The component will be followed if call is hold
successfully.

Error Goto The component will be followed if call is not able to
hold it.
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2.3.1.5.8  Disconnect Call

This component is used to disconnect a connected call. Click  and drag it into
your call flow. Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

SIP Reason Code The SIP reason code will be used to reject if call is
not connected yet.

Error Goto The component will be followed if call is not able to
hold it.

2.3.1.5.9  Disconnecting Start Event

This component will be executed when call is disconnected.  This component will be
triggered to run when a connected call was disconnected no matter whether it is
disconnected by remote or local. If call flow is running into Critical Start/Stop pair,
this will wait Critical Stop executed and start this Disconnect Start Event. You can do
some processing such as DB access, execute a HTTP Hook etc by using this

components/   Click  and drag it into your call flow. Right click the component
and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Next Goto The following component will be followed when a
connected call is disconnected.

2.3.1.6 IVR Component

The General component contains the IVR related components. Click  as the
following components will be display for your selection:
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2.3.1.6.1  Play Prompt

This component is used to play announcement file to remote party. Click  and
drag it into your call flow. Right click the component and the properties will be display
as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Prompt Directory The sub-directory for the prompt based on the system
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Parameter Name Description

prompt directory

Prompt Mode The system support the following types of prompt play
back mode:
1. Normal Play: In this mode, the system will play all
prompts once
2. Repeat Play: In this mode, the system will play all
prompts one by one and repeat it.
3. Repeat Background Play: In this mode, the system
will play all prompts one by one and repeat it until a
stop play or another play prompt related components.
The system will play it background and move to next
component (Next Goto). Thus IVR can do other
process such as execute a HOOK or DB query.

Interrupt Key Whether DTMF will stop the play or not? It is only valid
when prompt mode is Normal Play or Repeat Play:
Disable: DTMF digit will be ignored.
Any Key: Any DTMF digit will stop the play.
Specified: Only specified DTMF digit will stop the
play. Others will be ignored.

Max Play Time Max time to run this component. It is useful when you
are play a prompt repeatedly.

Prompt Type The Prompt Type contains the different source to be
played as follows:
1. Prompt File: Play a wav format file which is Linear
PCM 16 bits, Mono, 8K sample rate.
2. TTS Date: Play date based on the selected
language. The input format is yyyy/mm/dd or mm/dd.
3. Time 24 hours: Play time in 24 hours format based
on the selected language. The input format is
hh:mm:ss or hh:mm.
4. Time 12 hours: Play time in 12 hours format based
on the selected language. The input format is
hh:mm:ss or hh:mm.
5. Currency: Play currency amount based on the
selected language
6. Numeric: Play numeric amount based on the
selected language
7. Digit: Play digit such as telephone number based
on the selected language.
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Parameter Name Description

Language The Text to Speech Language. It will be ignored for
prompt file.

Content The contents to be played. It could be a variable or
value.

Next Goto The component will be followed if play announcement
is success.

Error Goto The component will be followed if play prompt is
failed.

2.3.1.6.2  Play Prompt and Collect Digit

This component is used to play announcement file to remote party and collect user

DTMF digits based on the rule. Click  and drag it into your call flow. Right click
the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Prompt Directory The sub-directory for the prompt based on the system
prompt directory
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Parameter Name Description

Regular Expression Whether to match additional to regular expression or
not?  Please refer to Appendix for the example of
regular expression. And you can test your regular
expression by using  http://regexpal.com/ before you
use it. The system system will start the regular
expression evaluation after min digits was receive
and stop if max digits is reached.

Min Digits The minimum digits to be received. 

Max Digits The maximum digits to be received

End of Key If specified, the system will think end of input if this
key was received. Normally, this key is #. And this
end of key will not be a part of result.

Need Match End of Key If it is enabled, the caller need input end of key.
Otherwise, the system will think the input is not
comply the requirements.

Digit Mask Whether to send DTMF when caller input DTMF
digits or not. Please contact FAE for detail.

Stop Prompt After Key
Press

Whether DTMF will stop the play or not? If it is not, the
play prompt will be continued until end of prompt or
matching the digit collecting requirement.

Collect Digit Variable The variable to  store the collected digits (not include
the end of key)

Prompt Type The Prompt Type contains the different source to be
played as follows:
1. Prompt File: Play a wav fromat file which is Linear
PCM 16 bits, Mono, 8K sample rate.
2. TTS Date: Play date based on the selected
language. The input format is yyyy/mm/dd or mm/dd.
3. Time 24 hours: Play time in 24 hours format based
on the selected language. The input format is
hh:mm:ss or hh:mm.
4. Time 12 hours: Play time in 12 hours format based
on the selected language. The input format is
hh:mm:ss or hh:mm.
5. Currency: Play currency amount based on the
selected language
6. Numeric: Play numeric amount based on the

http://regexpal.com/
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Parameter Name Description

selected language
7. Digit: Play digit such as telephone number based
on the selected language.

Language The Text to Speech Language. It will be ignored for
prompt file.

Content The contents to be played. It could be a variable or
value.

Next Goto The component will be followed if collected digits is
comply to the settings.

Error Goto The component will be followed if collected digits is
not comply to the settings.

Timeout Goto The component will be followed if no any digits was
received.

2.3.1.6.3  Play Prompt and Collect Digit with Retry

This component is used to play announcement file to remote party and collect user

DTMF digits based on the rule. Click  and drag it into your call flow. Right click
the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Prompt Directory The sub-directory for the prompt based on the system
prompt directory

Regular Expression Whether to match additional to regular expression or
not?  Please refer to Appendix for the example of
regular expression. And you can test your regular
expression by using  http://regexpal.com/ before you

http://regexpal.com/
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Parameter Name Description

use it. The system will start the regular expression
evaluation after min digits was receive and stop if
max digits is reached.

Min Digits The minimum digits to be received. 

Max Digits The maximum digits to be received

End of Key If specified, the system will think end of input if this
key was received. Normally, this key is #. And this
end of key will not be a part of result.

Need Match End of Key If it is enabled, the caller need input end of key. 
Otherwise, the system will think the input is not
comply the requirements.  When enable this feature,
the min and max digits need to be add 1 more for the
end of key. 

Digit Mask Whether to send DTMF when caller input DTMF
digits or not. Please contact FAE for detail.

Stop Prompt After Key
Press

Whether DTMF will stop the play or not? If it is not, the
play prompt will be continued until end of prompt or
matching the digit collecting requirement.

Collect Digit Variable The variable to  store the collected digits (not include
the end of key)

Max Retry Count The max retry count if the input cannot match the
component requirements.

Invalid Input Prompt The system will play this prompt if the input is not
match the component requirements such as min/max
digits, regular expression, end of key etc.

Time Out Error Prompt The system will play this prompt if remote party
doesn't input any digits.

Prompt Type The Prompt Type contains the different source to be
played as follows:
1. Prompt File: Play a wav format file which is Linear
PCM 16 bits, Mono, 8K sample rate.
2. TTS Date: Play date based on the selected
language. The input format is yyyy/mm/dd or mm/dd.
3. Time 24 hours: Play time in 24 hours format based
on the selected language. The input format is
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Parameter Name Description

hh:mm:ss or hh:mm.
4. Time 12 hours: Play time in 12 hours format based
on the selected language. The input format is
hh:mm:ss or hh:mm.
5. Currency: Play currency amount based on the
selected language
6. Numeric: Play numeric amount based on the
selected language
7. Digit: Play digit such as telephone number based
on the selected language.

Language The Text to Speech Language. It will be ignored for
prompt file.

Content The contents to be played. It could be a variable or
value.

Next Goto The component will be followed if collected digits is
comply to the settings.

Over Max Retry Goto The component will be followed if over max retry
count 

2.3.1.6.4  IVR Menu

This component is used to play announcement, ask input and switch to different

component based on the user input. Click  and drag it into your call flow. Right
click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Prompt Directory The sub-directory for the prompt based on the system
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Parameter Name Description

prompt directory

Number of Digits Number of digits to be received.

Stop Prompt After Key
Press

Whether DTMF will stop the play or not? If it is not, the
play prompt will be continued until end of prompt or
matching the digit collecting requirement.

Collected Digit Variable The variable to store the inputted digits.

Max Retry Count The max retry count if the input cannot match the
component requirements.

Invalid Input Prompt The system will play this prompt if the input is not
match the component requirements such as min/max
digits, regular expression, end of key etc.

Time Out Error Prompt The system will play this prompt if remote party
doesn't input any digits.

Prompt Type The Prompt Type contains the different source to be
played as follows:
1. Prompt File: Play a wav format file which is Linear
PCM 16 bits, Mono, 8K sample rate.
2. TTS Date: Play date based on the selected
language. The input format is yyyy/mm/dd or mm/dd.
3. Time 24 hours: Play time in 24 hours format based
on the selected language. The input format is
hh:mm:ss or hh:mm.
4. Time 12 hours: Play time in 12 hours format based
on the selected language. The input format is
hh:mm:ss or hh:mm.
5. Currency: Play currency amount based on the
selected language
6. Numeric: Play numeric amount based on the
selected language
7. Digit: Play digit such as telephone number based
on the selected language.

Language The Text to Speech Language. It will be ignored for
prompt file.

Content The contents to be played. It could be a variable or
value.
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Parameter Name Description

Digit/Goto If the receive digits matched this digits settings, the
goto will be the component to be run. 

Over Max Retry Goto The component will be followed if over max retry
count 

2.3.1.6.5  IVR Random Menu Switch

This component is used to play announcements, record a file and switch to different
component by random select one switch. I t could be useful for a IVR training. Click 

 and drag it into your call flow. Right click the component and the properties will
be display as follows:
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Play

The detail of each parameter is described as below:
  

Parameter Name Description

Prompt Directory The sub-directory for the prompt based on the system
prompt directory
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Parameter Name Description

Recording Prompt
Directory

The sub-directory for the recorded file based on the
system prompt directory

Recording File Name The file name for the recorded voice

Max Recording Time The max time to record 

Recording End Key The key to indicate end of the recording. It is normally
a # key.

Play Beep Whether to play beep to tell remote party the starting
of recording.

Silence as End of
Recording

Whether detect silence to see whether the voice
recording was completed or not?

Stream ID What is the stream ID will be send to remote server
such as ASR or other server. It can also use
component ID as a reference ID. This stream ID will
be use to know what kind of ASR service will be used
or other purpose.

Send PCM Stream Whether start the PCM stream sending or not?
Please only start it when you have a server to receive
the real time stream. It will sending the real time
stream by UDP as the following:
channel ID: short
Steam ID: int
Sequence ID: unsigned short
Payload Length: short 
Payload Data:  8K, 16 bits, Liner PCM data will be
sent to peer server. 100 ms (1600 bytes) is the max
payload size.

Prompt Type The Prompt Type contains the different source to be
played as follows:
1. Prompt File: Play a wav format file which is Linear
PCM 16 bits, Mono, 8K sample rate.
2. TTS Date: Play date based on the selected
language. The input format is yyyy/mm/dd or mm/dd.
3. Time 24 hours: Play time in 24 hours format based
on the selected language. The input format is
hh:mm:ss or hh:mm.
4. Time 12 hours: Play time in 12 hours format based
on the selected language. The input format is
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Parameter Name Description

hh:mm:ss or hh:mm.
5. Currency: Play currency amount based on the
selected language
6. Numeric: Play numeric amount based on the
selected language
7. Digit: Play digit such as telephone number based
on the selected language.

Language The Text to Speech Language. It will be ignored for
prompt file.

Content The contents to be played. It could be a variable or
value.

Goto The system will random choice next component when
this goto had next component.

2.3.1.6.6  Stop Play

This component is used to stop a background playing. Click  and drag it into
your call flow. Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Next Goto The component will be followed after stopped the
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Parameter Name Description

playing.

2.3.1.6.7  Record Voice File

This component is used to record a file. Click  and drag it into your call flow.
Right click the component and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Recording Prompt
Directory

The sub-directory for the recorded file based on the
system prompt directory

Recording File Name The file name for the recorded voice

Max Recording Time The max time to record 
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Parameter Name Description

Recording End Key The key to indicate end of the recording. It is normally
a # key.

Play Beep Whether to play beep to tell remote party the starting
of recording.

Silence as End of
Recording

Whether detect silence to see whether the voice
recording was completed or not?

Stream ID What is the stream ID will be send to remote server
such as ASR or other server. It can also use
component ID as a reference ID. This stream ID will
be use to know what kind of ASR service will be used
or other purpose.

Send PCM Stream Whether start the PCM stream sending or not?
Please only start it when you have a server to receive
the real time stream. It will sending the real time
stream by UDP as the following:
channel ID: short
Steam ID: int
Sequence ID: unsigned short
Payload Length: short 
Payload Data:  8K, 16 bits, Liner PCM data will be
sent to peer server. 100 ms (1600 bytes) is the max
payload size.

Next Goto The next component when complete the recording

Error Goto The next component when there is a error found

2.3.1.6.8  Dial DTMF Digits

This component is used to send DTMF to the remote party. Click  and drag it
into your call flow. Right click the component and the properties will be display as
follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Send DTMF The DTMF string to be send. It could be 1 or multiple
digits

Next Goto The component will be followed after send the DTMF
out

2.3.1.6.9  Digit Timeout

This component is used to change the first digit and inter digit time out. It will

overwrite the existing settings.  Click  and drag it into your call flow. Right click
the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

First Digit Time Out The max waiting time for first digit

Inter Digit Time Out The max waiting time between digits after received
first digit

Next Goto The component will be followed after send the fax out

2.3.1.6.10  Send Fax

This component is used to send a fax file  to the remote party (fax resource license
required). The file name must have extension of .tff and its format is G4 compression

and 1728 width. Click  and drag it into your call flow. Right click the component
and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Fax Answer Timeout The max time to wait remote party fax to answer the
fax

Max Fax Sending Time The max time to send a fax 

Fax Directory The directory which  contains the sending fax file 

Fax Sending File Name The fax sending file name (need end with .tiff). The tiff
format is:
 Width: 1728
Compression: G4
It will be easier to use Call Flow- -> Prompt/Fax
Manger to upload a tiff or pdf from it. The upload will
do the conversion automatically.

Error Detail Information In case the fax had error, this is the variable to store
the detail error information.

Number of Fax Pages This is the variable to store the pages transmitted.
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Parameter Name Description

Next Goto The component will be followed after send the fax out

Error Goto If the fax encountered an error, this is the next cid will
go.

2.3.1.6.11  Receive Fax

This component is used to receive fax from the remote party  (fax resource license

required). Click  and drag it into your call flow. Right click the component and
the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Max Fax Receiving Time The max time to receive a fax

Fax Directory The directory which  contains the sending fax file 
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Parameter Name Description

Fax Remote ID Fax remote party ID

Fax Receiving File Name The received fax file name in tiff extension. 
The received tiff format is:
   Width: 1728
   Compression: G4

Error Detail Information In case the fax had error, this is the variable to store
the detail error information.

Number of Fax Pages This is the variable to store the pages received.

Next Goto The component will be followed after send the fax out

Error Goto If the fax encountered an error, this is the next cid will
go.

2.3.1.7 Database Component

The General components contains the database related components. Click  as
the following components will be display for your selection. To use database
component, UnixODBC need to be installed and an odbc setting need to be done as
a source name.

 

2.3.1.7.1  DB Connect

This component is used to request a DB connection to a data source. You need
setup UNIX ODBC data source setting out of IVR in order to use the DB

components.  Click  and drag it into your call flow. Right click the component
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and the properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Data Source Name The data source name in UNIX ODBC 

DB User ID The Database User

DB User Password The Database Password

Connect Time Out The max connecting time to the DB server in seconds

Next Goto The next component if DB connection is created

Error Goto The next component if failed to create the required
DB connection

2.3.1.7.2  DB Disconnect

This component is used to disconnect  a DB source when it is not used.  Click 
and drag it into your call flow. Right click the component and the properties will be
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display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Data Source Name The data source name in UNIX ODBC 

Next Goto The next component after disconnect the DB source

2.3.1.7.3  Transaction Start

This component is used to start a DB transaction.  Click  and drag it into your
call flow. Right click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Data Source Name The data source name in UNIX ODBC 

Next Goto The next component if DB transaction was started
successfully

Error Goto The next component if DB transaction was failed to
start

2.3.1.7.4  Transaction Stop

This component is used to stop a DB transaction.  Click  and drag it into your
call flow. Right click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Data Source Name The data source name in UNIX ODBC 

Commit or Rollback Whether this transaction is going to be committed or
rolled back? 
Yes: Commit
No: Rollback

Next Goto The next component if DB transaction was started
successfully

Error Goto The next component if DB transaction was failed to
start

2.3.1.7.5  SQL Exectute

This component is used to execute a SQL command. To bind your variable into

SQL, you can use SQL input variable and mapped variable.  Click  and drag it
into your call flow. Right click the component and the properties will be display as
follows:
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The detail of each parameter is described as below:
  

Parameter Name Description
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SQL Result Alias Name If the SQL is a query SQL, this is the alias name to be
used to store the SQL result. You can use SQL fetch
to get the result by using this alias name. 

Data Source Name The data source name in UNIX ODBC 

Result Count The variable to store the result counter. If it is a query
SQL, this is the number of records found. If it is a
update or delete SQL, this is the number of records
deleted or updated.

Max Execution Time Max time to execute this SQL command

SQL Command The SQL command to be executed

SQL  Input Variable This is the keyword to be replaced in the SQL URL.
The system will look at the SQL URL and find those
keywords (SQL Input Variable)  and replace it by
using the value of "Replaced Variable". This is useful
to make the SQL URL based on your collected data.

Mapped Variable This is the mapped variable which value will replace
the corresponding keyword in SQL Input Variable.

Next Goto If SQL command is executed successfully, this
component will be followed.

Error Goto If SQL command is failed to execute, this component
will be followed.

2.3.1.7.6  SQL Fetch

This component is used to get a record from the result set of SQL. Click  and
drag it into your call flow. Right click the component and the properties will be display
as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

SQL Result Alias Name This is the alias name from SQL execute. 

Data Source Name The data source name in UNIX ODBC 
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Fetch Mode The retrieve mode to get the record from the result
set

Column Index/Stored
Variable

The variable to store the result for each column index

Next Goto If  result is fetched successfully, this component will
be followed.

Error Goto If result is  failed to be fetched, this component will be
followed.

Not Found Goto If there is no data in this result set, this component will
be followed

2.3.1.8 ACD Component

The General component contains the ACD related components. Click  as the
following components will be display for your selection:

 

2.3.1.8.1  ACD-DN Status

This component is used to get the current ACD-DN status.  Click  and drag it
into your call flow. Right click the component and the properties will be display as
follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

ACD Server IP Address The ACD server IP address. 

ACD DN The ACD DN to be queried

Answered Count The counter of answered calls

Abandoned Count The counter of abandoned calls

Current Queued Calls Number of calls currently in the queue

Longest Waiting Time Longest waiting time of this ACD-DN

Service Level The service level of this ACD-DN

Login Count Number of agents login to the system

Ready Count Number of agents in Ready state

Not Ready Count Number of agents in Not Ready state
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Busy Count Number of agents in Busy state

AUX Count Number of agents in AUX state

Rest Count Number of agents in Rest state

After Call Work Count Number of agents in After Call Work state

Average Talking Time Average  Agent Talking Time 

Average Handling Time Average  Handling Time  which include ACW and
Talking Time.

Next Goto The next component if ACD-DN Status was retrieved
successfully.

Error Goto The next component if failed to retrieve ACD-DN
status from server

2.3.1.8.2  Call Back Reservation

This component is used to make a reservation of call back to ACD server.  If IVR
server is not running in the same server of ACD,  you need have an ODBC

connection setting in UNIX ODBC in order to access ACD database.   Click 
and drag it into your call flow. Right click the component and the properties will be
display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Call Back Number The number to be called back

CTI Data The CTI data will be used when call back ( from Wait
Incoming Call Skill Variable)

Skill The Skill will be used when call back ( from Wait
Incoming Call Skill Variable)

Record File Name The file name to record customer message which will
be play back to agent if there is one.

Incoming ACD DN The incoming ACD-DN (normally, it is coming from
Wait Incoming Call Diversion Variable)

Success Goto The next component if call back reservation was
registered successfully.

Error Goto The next component if failed to register this call back
request to server
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2.3.1.8.3  Get Call Back Request

This component is used to get a call back request from ACD server.  Click 
and drag it into your call flow. Right click the component and the properties will be
display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Call Back Number The variable to store the number to be called back
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Parameter Name Description

CTI Data The variable to store the  CTI data will be used when
call back

Skill The variable to store the  Skill will be used when call
back

Record File Name The variable to store the file name of recorded
customer message which will be play back to agent.

Incoming ACD DN The variable to store the  incoming ACD-DN

Outgoing ACD DN The variable to store the  outgoing ACD-DN to
agents which handle the call back request

Wait Answer Notice The variable to store that whether to wait answer
notice when dialing out to customer or not? It need
VOIP gateway to support this feature. Please contact
FAE for detail.

Wait Time Out (secs) The variable to store the waiting time for  VOIP
gateway to report the result of answering detect.

Reservation Time The variable to store the time of reservation.

Check this DN only When check this DN only is checked, the IVR will get
this DN's call back request only. If it is not checked, all
DN's call back request will. 

Voice Message Goto The next component if a call back request was found
and it need leave  customer voice message.

No Voice Message Goto The next component if a call back request was found
and it doesn't need leave  customer voice message.

Not Found Goto The next component if failed to get a call back
request from server

Call Back ANI The calling number (ANI) will be used for this call
back service.
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2.3.1.8.4  Update Call Back History

This component is used to update the current call back request to ACD server. 

Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Call Result The variable for the call result from Call Making
component

Success Goto The next component if update is success

Not Found Goto The next component if failed to update

2.3.1.8.5  Get Dialing List

This component is used to get a call back request from IVR DB.  Click  and
drag it into your call flow. Right click the component and the properties will be display
as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Dial ID An unique ID for this dialing 

Called Number The number to be dialed

Calling Number The calling number to be used

CTI Data The variable to store the  CTI data will be used when
call back
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Parameter Name Description

Skill The variable to store the  Skill will be used when call
back

Outgoing ACD DN The variable to store the  outgoing ACD-DN to
agents which handle the dialing our request if this call
required to transfer to agent.

Wait Answer Notice The variable to store that whether to wait answer
notice when dialing out to customer or not? It need
VOIP gateway to support this feature. Please contact
FAE for detail.

Wait Time Out (secs) The variable to store the waiting time for  VOIP
gateway to report the result of answering detect.

ACD Center ID This variable is for input (when Check this center only
is checked) and output (when Check this center only
is not checked).

Check this Center only When check this center only is checked, the IVR will
get this center's dialing list only. If it is not checked,
Center ID filed will be ignored.

Optional Dialing Info The variable to store the additional dialing
information

Voice Call Goto The next component if a dialing list was found and it
is a voice call request

Fax Call Goto The next component if a dialing list was found and it
is a fax call request

Not Found Goto The next component if failed to get a dialing list  from
server

2.3.1.8.6  Update Dialing List

This component is used to update the current dialing list result  to IVR server.  Click 

 and drag it into your call flow. Right click the component and the properties will
be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Wait Time Out (secs) The time to wait the update result

SIP Result Code The variable for the call result from Call Making
component

ACD Server IP Address The ACD Server IP address which is used to update
ACD related call service information. It could be
empty to ignore the updating if the customer is not
using FAX calling out feature from ACD.

Optional Dialing Info The variable to update the additional dialing
information

Success Goto The next component if update is success

Not Found Goto The next component if failed to update
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2.3.1.8.7  CTI Data Build

This component is used to build ACD required CTI or Skill data variable from input

value or variable.  Click  and drag it into your call flow. Right click the
component and the properties will be display as follows:

The detail of each parameter is described as below:
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Parameter Name Description

CTI Output Variable Combined result of CTI data

Skill Output Variable Combined result of Skill data

CTI Data Up-to 10 variable or constant value can  be added to
CTI Output Variable.

Skill Data Up-to 10 variable or constant value can be added to
Skill Output Variable

Next Goto The next component to be executed

2.3.1.8.8  CTI Data Divider

This component is used to divide received CTI data into individual CTI or Skill data

variable.  Click  and drag it into your call flow. Right click the component and
the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

CTI Input Variable Received CTI Data

Skill Input Variable Received Skill data

CTI Data Up-to 10 variable can  be used to store individual
data from received CTI data
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Parameter Name Description

Skill Data Up-to 10 variable can  be used to store individual
data from received Skill data

Next Goto The next component to be executed

2.3.1.8.9  CTI Agent Listen Control

This component is used to control the CTI agent can hear the voice played by IVR or
not. It can be only working with our own ACD server and only when agent use ACD
command to transfer to IVR for some automatic service.. It is useful when IVR is

playing the ID or password and would like to make the Agent to hear it. Click 
and drag it into your call flow. Right click the component and the properties will be
display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

Mute IVR Yes: Agent will not able to hear the voice played by
IVR (mute)
No: Agent will able to hear the voice played by IVR
(unmute)

Next Goto The next component to be executed if succeed



Using the System

 
133

Parameter Name Description

Error Goto The next component to be executed if an error is
occurred.

2.3.1.8.10  CTI Data Update

This component is used to update ACD CTI attached data for future usage. It can be
only working with our own ACD server and only when agent use ACD command to
transfer to IVR for some automatic service.  It is useful when IVR need update CTI
data to agent when it collected some new information.  After this component, Agent
Desktop will receive "CTI Data Changed Event (9005)" event to tell new CTI data.

Click  and drag it into your call flow. Right click the component and the
properties will be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

CTI Attached Data The new CTI attached data will be replaced.

Next Goto The next component to be executed if succeed

Error Goto The next component to be executed if an error is
occurred.
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2.3.1.8.11  ACD File Generator

This component is used generate a file name which comply with ACD multi-media
request for such as FAX or voice message service. The generated file name could
be used to be the file name of receiving fax or voice recording name. After the fax
file or voice file was received, the call flow should use ACD multimedia request
component to put this file into ACD server and dispatch to agent to service. Click 

 and drag it into your call flow. Right click the component and the properties will
be display as follows:

The detail of each parameter is described as below:
  

Parameter Name Description

File Name Type The file type for generated file name. 
FAX Message: xxxxxxx.tiff will be generated
Voice Message: xxxx.wav will be generated
The generated file name will be like
yyyymmddhhmmss-xxxxxxxx.tiff (for fax message),
yyyymmddhhmmss-xxxxxxxx.wav (for wav). xxxxxxxx is
an random number for make it unique.
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Parameter Name Description

Directory Prefix: The stored file directory value or variable under
system user data ($IVR/userdata). To make it work,
the directory need able to be accessed by both IVR
and ACD server. It is recommended to use an link (if
it is in the same machine) or NFS when both server
are not in the same server.

ACD Center ID The ACD Center ID for this file.  

Directory Stored Variable The output variable to be used as a directory variable
in recording or fax receiving components.

File Name Stored
Variable

The output variable to be used as a file name variable
in recording or fax receiving components.

Next Goto The next component to be executed if succeed

Example:
Input Information:
  File Name Type: Fax Message
  Directory Prefix: faxdata
  ACD Center ID: center99
  Current Date Time: 2014/06/27 10:20:30

Output variable:
   Directory Stored Variable:  faxdata/center99/201406/27
   File Name Stored Variable: 20140627102030-7F2A33.tiff

When this is used by the recording or fax receiving, the system will create the
corresponding directory automatically. 

2.3.1.8.12  ACD Multimedia Request

This component is to be used for making the recorded voice message or fax
message become a ACD service request. It can only be working with our own ACD
server. There are some integration requirements to make both IVR and ACD sharing

the same directory. Please contact technical support.  Click  and drag it into
your call flow. Right click the component and the properties will be display as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

ACD Server IP The ACD server IP address

ACD DN The ACD DN will be dispatched to for this voice/fax
message.

ACD Center ID Center ID from ACD server

Message Type Fax message: By using fax receive
Voice message: By using voice message

Caller ID Calling party number for identifying the caller.

Skill Information Skill ID list separated by a comma (if multiple skill is
required)
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Parameter Name Description

CTI Attached Data CTI attached data separated by a comma (if multiple
CTI data is required)

Message File Name
Variable

The message file name variable getting from ACD
Multimedia Request.

Next Goto The next component to be executed if succeed

Error Goto The next component to be executed if an error is
occurred.

2.3.2 Channel Manager

Channel Manager is to be used manager each IVR channels. you can load, unload,
run, stop or debug 1 or more channels by selecting them. Click CALL FLOW ->
Channel Manager and the following will appear:

The detail of each column is described as below:
  

Parameter Name Description

Channel ID The IVR channel ID 
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Parameter Name Description

Status The current status of this channel

Connect Time The call  connected time

Startup Call Flow The start-up call flow name

Update Seq ID The Start Call Flow's update seq ID

Current Call Flow The current call flow which could be start-up call flow
or sub flow.

Calling The calling party number

Called The called party number

Prefix This is the incoming call prefix need to be matched.
Only available when Call Type is incoming call.

Call ID SIP Call ID

Call Type This field indicate the call flow type is incoming call or
outgoing call.

Select one or more channel ID and right click, the following will appear:
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You can do the load, reload, run, stop, unload or debug for this channel.

The following button is used to handle multiple channels as follows. Click load,
unload or run button and the following will appear:
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Select those channels to right windows and click Apply. The following will appear:

 
Select the call flow to apply to those channels and click Apply. 

2.3.2.1 Debug a Channel

To debug a channel, right click and select debug in the channel manager and the
following will appear. You can see the current component running, variable value and
debug message as follows:
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2.3.3 Information Group

Information Group is used to associated into a call flow. Multiple call flow can use
same information group if need. Each information group contains holiday, working
hour and digit manipulation information. Click CALL FLOW -> Information Group and
the following will appear:

Click New to create an information group as follows:
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The detail of each parameter is described as below:
  

Parameter Name Description

Group ID The ID of information group

Description The description of this information group

2.3.3.1 Holiday

Click Holiday for an information group, the following will appear:

Click New to add a new holiday into this information group and the following will
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appear:

The detail of each parameter is described as below:
  

Parameter Name Description

Group ID The ID of information group

Holiday The holiday will be inserted 

Prompt File This is the prompt for this holiday and it can be
retrieved by IVR for playing back in call flow.

Description The description of this holiday

2.3.3.2 Working Hour Type

You can define working type for this information group which will be used for working
hour settings.  In you call flow, you can retrieve this working type to have different call
scenario. 
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Click New to add a new working hour type  into this information group and the
following will appear:

The detail of each parameter is described as below:
  

Parameter Name Description

Group ID The ID of information group

Working Hour Type The working hour type definition which can be
retrieved by IVR for play different voice prompt. It
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Parameter Name Description

could be lunch, tea, breakfast etc.

Display Color The color will be display for this working hour type

Description The description of this working hour type

2.3.3.3 Working Hour

Click Working Hour for an information group, the following will appear:

Click the period you would like to make it as a working hour by selecting different
working hour type. The different color indicate different working hour type based on
you settings.

2.3.3.4 Special Day

The special day is a day which had a special working settings. Click Special Day for
an information group, the following will appear:
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Click New to add a new special day  into this information group and the following will
appear:

The detail of each parameter is described as below:
  

Parameter Name Description

Group ID The ID of information group

Date The special date 

Working Hour Click the period you would like to make it as a
working hour by selecting different working hour type.
The different color indicate different working hour type
based on you settings.
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2.3.3.5 Digit Manipulation

Click Digit Manipulation for an information group, the following will appear:

Click New to add a new Digit Manipulation rule  into this information group and the
following will appear:

The detail of each parameter is described as below:
  

Parameter Name Description

Group ID The ID of information group

Mode Whether enable or disable this rule?

Pilot Number The leading number (prefix) to be matched

Length The incoming number requires to have the same
length in order to enable this digit manipulation rule. 
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Parameter Name Description

Click "ignore" to ignore the length matching. 

Start Position The start position to be replaced. Before the first
digit, the position is 0. Between digit 1 and digit 2,
the position is 1 and so on.  If the position is greater
than the digit length, it indicates after last digit.

Stop Position The stop position to be replaced. Before the first
digit, the position is 0. Between digit 1 and digit 2,
the position is 1 and so on. If the position is greater
than the digit length, it indicates after last digit.

Replace Value The value to be placed after remove the digit in
between start and stop position. You can keep it
empty if only required to delete those digits in
between start and stop. The following are the
examples of the DM rule:
Number to be DM: 1234567, Start position: 0, stop
position: 0, Replaced value: "002", DM result:
0021234567.
Number to be DM: 1234567, start position: 2, stop
position: 6, replaced value: "002", DM result:120027
Number to be DM: 1234567, start position: 24, stop
position: 24, replace value: "002", DM result:
1234567002.
Number to be DM: 1234567, start position: 1, stop
position: 2, replaced value: "", DM result:134567.

2.3.4 Prompt/Fax Manager

Click CALL FLOW -> Prompt/Fax Manager (if fax license is grated) or CALL FLOW
-> Prompt Manager (without fax license) and you will able to manage your prompt or
fax  file by using web GUI.

The supported voice prompt file format is:
- 8K Sample Rate
- 16 bits
- Linear PCM (signed)
- Mono 
- Wav format

The supported fax file format are pdf and tiff. The system will automatically convert
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the received pdf or tiff into standard format for fax system. It might take longer time if
the input file has multiple pages.

The manager is an explore like manager as follows:

You can create directory, upload, download, delete or rename the file etc. by using
the prompt manager icon.

2.3.5 Dial List

Dialing List is used to check and verify the dialing request from web, ACD or
external system. For example, a FAX request could be issued from ACD and the
administrator can check the integration from Dial List. Click Call Flow -> Dial List
and the following will appear:

The detail of each parameter is described as below:
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Parameter Name Description

Ready Call Time Targeted time to be used for dialing

Call Time Last Calling Time

Dial ID Unique dialing reference ID

Center ID If it is coming from ACD, this is requested Center ID

ACD DN If it is coming from ACD, this is requested ACD DN

State Current dialing state which includes:
0: Wait To Dial
1: Dispatched
2: Dialed
3: Failed

Called TEL Called Number 

Calling TEL Calling Number (ANI)

Type Call type:
FAX: It is a fax call
Voice: It is a voice call

Call Result Latest SIP Call Result 

Reference ID Reference ID which can be used to be referred to
ACD or external system

Last Retry Count Last Retry Counter

Max Retry Count Max Retry for this dialing request

Retry Interval (Seconds) Retry Interval in Seconds

CTI Data CTI Data for this call

Skill Info Skill Information for this dialing

Dial Info 1-3 Private Dialing Information for this dialing which could
be used for dialing parameters

Click Detail and the following will appear:



Using the System

 
151

Click Re-Dispatch to request IVR to dial again.
Click Delete to remove this dialing request.

2.4 Report

The system  provides system statistic, system alerting, call flow wide alert and debug
reports for management purpose.  

2.4.1 System Performance Report

The system provides hourly or daily performance report for each IVR channels. Click
REPORT -> System Performance Report and the following will appear:
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The detail of each report field is described as follows:

Field Name Description

Channel ID IVR channel ID. Channel 0 indicate whole system wide
statistic. And call flow based Peak Failure IVR attempt
can be found on Call Flow's lowest running channel for
diagnostic purpose. For example, call flow A is running
on the channels 7,8,9,10. The call flow A's statistic will
be summarized at channel 7.

Time The statistic time

Total IVR Attempt Total IVR call attempts during this period

Total Failed IVR Attempt Total IVR call attempts which is not answered or failure
during this period. The lowest running channel for the
same call flow will summaries the total failed IVR
attempt for administrator to see if the call flow's running
channel need increase or not.

Peak IVR Attempt Peak IVR call attempts

Current IVR Attempt Current IVR call attempts 

Total IVR Used Total IVR serviced during this period
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Field Name Description

Peak IVR Used Peak IVR used 

Current IVR Used Current IVR used

Total IVR Service Time Total IVR service time during this period

Longest IVR Service
Time

Longest IVR service time during this period

Average Service Time Average IVR service time during this period

2.4.2 System Alert Report

This report provides system alert notice report. The administrator can use it to
understand when and which service had problem. Click REPORT -> System Alert
to view the report.

The detail of each report field is described as follows:

Field Name Description

Time The system alert notice event time

Service The service which generated the event
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Field Name Description

Level  The level of this event

Description The system alert notice content

2.4.3 Call Flow Alert Report

This report provides call flow alert report which is generated  by System Event
Message component.   Click REPORT -> Call Flow Alert Report to view the report.

The detail of each report field is described as follows:

Field Name Description

Alert Time The call flow alert notice event time

Channel ID The channel ID for generating this event

Level  The level of this event

Message The call flow alert notice content
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2.4.4 Call Flow Log

This report provides call flow debug message report which is generated  by Debug
Message component.  Click REPORT -> Call Flow Log to view the report.

You can download to check it if it is big.

2.4.5 Web Provisioning

The system will record down all the access to the system from web. The
administrator can use it to audit the system and tracking the changes. Click 
REPORT -> Web Provisioning to view the report as follows:
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The detail of each report field is described as follows:

Field Name Description

Time The time to access web 

Target The web target to be accessed

Operation The operation madden by user

Modifier The user who made the change

Authorization The login user's authorization

Login IP The IP address of user

Update Value The value changed detail

Select one of record and click the Detail button. The following detail for such record
will appear.

2.4.6 Fax Statistic

Fax statistic report contains the fax resource utilization and peak resource usage for
administrator to check whether need increase license or not. Also it includes the fax
sending/receiving failure which could lead the administrator to check whether the fax
compatible or line issues. Click Report -> Fax Statistic and the following will appear:
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The detail of each report field is described as follows:

Field Name Description

Period The statistic period

Max Fax Resource Granted fax resource license

Total Fax CA The fax call attempt during this period

Fax Resource
Utilization 

The utilization of licensed fax resource

Total Fax Req
Failure

Number of failures to get fax T.38 resource when a FAX
resource is requested

Total Snd/Recv
Failure

Number of failures that the sending fax or receiving fax
cannot be completed which might be caused by transport
quality or fax compatible issues etc.

Peak Fax CA Peak fax resource request received during this period

Peak Fax Used Peak fax resource were used during this period

Total Fax used Total fax resource  were used  during this period
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2.4.7 Call History Report

This report provides call detail record report. Click REPORT -> Call History Report
and the following will appear:

The detail of each report field is described as follows:

Field Name Description

Channel ID IVR Channel ID

Call Flow Name Call flow is used for this channel ID

Update Sequence
ID

Call flow sequence is used for this channel ID

Start Time Channel starting service time

Stop Time Channel stop service time

Caller Calling party number

Called Called party number

Duration Service time in seconds

Call Type Incoming call or outgoing call type

In CTI Data Incoming CTI data if existed

Out CTI Data outgoing CTI data if existed

Out Skill Data outgoing Skill data if existed
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Field Name Description

Universal Call ID Global unique call ID can be traced in between systems.

2.4.7.1 Key Path

Key path provides a way to analyze customer behavior. For each call history record,
you can click Key Path button to see the detail of customer key path in flow or list as
follows:

The flow started by service start time and end with service stop time. For each
customer traced key path it includes:

Key Time (Escape time in seconds since start)
Key Tag: Recorded key tag name
Key Value: Recorded key value on Key Path Trace Component

Click List and you will see the following:
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The detail of each report field is described as follows:

Field Name Description

Key Sequence Key happened sequence 

Key Time The time to enter this key path trace compoent

Key Tag The key traced tag name for reporting purpose

Key Value The key trace tag value

2.4.8 Key Path Report

Key Path Report provides a customized key path statistic report or chart to analyze
customer behavior. Click REPORT -> Key Path Report and input the search criteria,
defined report template. The selected customized report will be displayed as
following example:
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The detail of each report field is described as follows:

Field Name Description

Channel ID IVR Channel ID

Time Statistic Time period or date

Call Count Service call count for this channel during the time period

Customized
Column...

Others are customizable column defined in key path report
template. 

Select the Chart report format and the following will appear:
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2.4.8.1 Key Path Report Template

Click Key Path Report Template button to customize your dedicate report as
following:

Click New and the following will appear:

The first step is import those defined Key Tag from a existing call flow. Click Import
From Call Flow and the following will appear:
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Select the required call flow and click apply. You can import multiple call flow's key
tag if required. After import, you will see all key tag you defined in call flow as follows:
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Modify the column title add the customer your need. In case you need more column, 
click Add Column to add a new column.

Click Apply and this customized report is ready to be used.

2.5 Diagnostic

The Diagnostic page provides real time monitoring for system, extension, call and
system log tracking. It could be very good tools to help administrator to identify the
root cause of problems. 

2.5.1 System Status

 System Status show the current status of service. Click DIAGNOSTIC -> System
Status to check the resource status as follows. 
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The detail of each filed is described as below:

The detail of each report field is described as follows:

Field Name Description

System  Release The IVR system release version

Web Release The IVR web release version 

System Startup Time The system start-up time

Total IVR Attempt Total IVR call attempts during this period

Total Failed IVR Attempt Total IVR call attempts which is not answered or failure
during this period

Peak IVR Attempt Peak IVR call attempts

Current IVR Attempt Current IVR call attempts 

Total IVR Used Total IVR serviced during this period

Peak IVR Used Peak IVR used 

Current IVR Used Current IVR used

Total IVR Service Time Total IVR service time during this period

Longest IVR Service
Time

Longest IVR service time during this period

Average IVR Service
Time

Average IVR service time during this period

Max Fax Resource Count Max Fax T.38 resource purchased

Total Fax CA Total Fax call attempt during this period

Total Fax Req Failure Number of failures to get fax T.38 resource when a
FAX resource is requested

Total Fax Snd/Recv
Failure

Number of failures that the sending fax or receiving fax
cannot be completed which might be caused by
transport quality or fax compatible issues etc.

Peak Fax CA Peak fax resource request received during this period

Current Fax CA Current fax resource request attempt

Peak Fax Used Total fax resource  were used  during this period

Current Fax Used Current fax resource  were used  during this period
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Field Name Description

Total Fax Used Total fax resource were used during this period

2.5.2 Ping

The administrator can ping a IP address from the host  by clicking DIAGNOSTIC ->
Ping. The following screen will appear.

Input the Host IP address and start the ping test.

2.5.3 System Information

Click DIAGNOSTIC -> System Information, you will able to see the current system
related setting,s including up time, hard disk, cpu, network information as follows:
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Click each button to see the different status. For detail, please refer to Linux
administration guide.

2.5.4 Call Capture

Call capture is a debug tool for tracking a call and suitable for low traffic mode. If you
need large traffic capture and analyze, you need have a qos monitor product to do it.
Click DIAGNOSTIC -> Call Capture and following will appear:

Select an network interface to capture and required packet filter, click Start Capture
to start the capture. Please make sure you stop the capture after you get required
packets. Otherwise, the capture might create a big file in your system and eat all
hard disk space.  Click "Get Capture File" to download the captured file to analyze.

2.6 Administration

The Administration setting includes the user account management, restart or
reboot the service. 

2.6.1 Restart Service

Click ADMINISTRATION -> Restart Service and the following pop screen will
appear.

Click Restart IVR Service  button to restart the IVR service.
Click Restart IVR/Fax Service  button to restart the IVR and IVR Media Service
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service (only available for Fax License).

2.6.2 Reboot System

Click ADMINISTRATION -> Reboot System and the following screen will appear.

Click Reboot button to reboot the whole machine.

2.6.3 Account

Click ADMINISTRATION -> Account to view the current settings of user account. 
The following screen will appear.

Click New to add a new user  and the following screen will appear.

The detail of each parameter is described as below:
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Field Name Description

User Mode Activate or de-activate the user

User ID The user ID to login 

Password The user password

Authorization The authorized role for the user. 

Language The web GUI language when the user login.

2.6.4 Upgrade System

Use Upgrade System to do the application patch by clicking ADMINISTRATION -
> Upgrade System. Please only use the certificated patch file to do the upgrade.
Otherwise, it will had problems.

After upgrade, reboot the machine to take effective.

2.6.5 Backup/Restore

Backup/Restore is used to backup the system configuration or restore it back. All the
configuration will be saved. Click ADMINISTRATION -> Backup/Restore to do the
backup to restore.

Select Backup System Configuration to backup the system configuration.
Select Restore System Configuration to restore it back.
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2.6.6 Clear Hitory Data

It is recommended to clean the unnecessary historical data periodically. Here is the
place to clean those historical data. Click Administration -> Clear History Data to
clean those historical data.

Select those data you want to delete, click apply to delete it.

2.6.7 Logout

To quit the management web for the current user, click ADMINISTRATION ->
Logout and the following pop screen will appear.

Click OK to logout.

2.7 Commit

After you change the system settings, you need to apply it by clicking the COMMIT
and the following popup screen will appear:
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Select OK  to commit the changes.

2.8 Help

The system provides pop up help hint when you move the cursor to the filed as
follows.

Also you can click HELP to see on line help which provides the same information as
this guide.
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3 Appendix

3.1 List of Used Network Ports

The following is the list of used TCP/IP ports. The network administrator can use it to
set the firewall when necessary.

Default
Ports

Proto
col 

Description Configuration Path

5063 UDP IVR UDP IPV4
SIP Port

SYSTEM ->SIP  Settings -> Local SIP IPV4
UDP Port

5067 UDP IVR UDP IPV6
SIP Port

SYSTEM -> SIP Settings ->  Local IPV4
IPV6 UDP Port 

40000-
41200

UDP IVR RTP port Each IVR channel will use up-to 4 rtp ports
which is allocated dynamically. The starting
port of the IVR can be changed on SYSTEM
-> Service Parameter -> Local Media UDP
Start Port 

2090 TCP IVR Control Port It is the port to control IVR channel manager,
status or debug.

7000 TCP HTTP  port  for 
administrator 

SYSTEM -> WEB Service -> HTTP Service
Port -> Administrator
Only be opened in firewall when necessary.

7001 TCP HTTPS port for
administrator

SYSTEM -> WEB Service -> HTTPS
Service Port -> Administrator
Only be opened in firewall when necessary.

7080 TCP SOAP
Provisioning Port

SYSTEM -> Web Service -> SOAP Service
Port
Only be opened in firewall when necessary.

3306 TCP MYSQL Service
Port

SYSTEM-> Database -> MYSQL Port 

3.2 Regular Expression Example

Here it the regular expression example based on POSIX standard:
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Matching Rule Regular
Expression

Matched Input

Match the prefix 886 and followed
by 8 digits including * and 0-9 

886[\d\*]{8} 88612345678
886*1234567

Match digit start with 9,8 or 7 and
followed by 4 digits (0-9)

[987]\d{4} 91234
81234

Match one of the following case:
Prefix is 123 and followed by 3
digits
Prefix is 234 and followed by 2
digits
Prefix is 66 and followed by 4 digits

^123\d{3}|̂ 234\d{2}|
^66\d{4}

123123
23422
661234

Not matched any prefix start with 2,
5, 7 or 9 and followed by 3 digits

[^2579]\d{3} 8111
6222

Start with * and followed by 3 digits
and #

[\*]\d{3}# *123#
*666#

Start with prefix 0932, 0933 or
0918 and followed by 4 digits

(0932|0933|0918)\d
{4}

09321234
09182222

1 digit and matched 1, 3, 5, 7 [13579] 3
1

3.3 System Internal Variable

The following is the read only system internal variable which can be used for debug
or other purpose.

Variable Name Description

_ERRNO Errno Number for debug purpose

_CHANID The running channel ID
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Variable Name Description

_HTTPOSTR HTTP request URL to send to http server for HOOK
request. It is mainly for debug purpose.

_SQLOSTR SQL string to send to DB for execution. It is mainly for
debug purpose

_HTTPPOSTR  HTTP request URL to send to http server for HOOK

_PREVCID Previous Component ID for debug tracking
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